"Submit" button on web form not working.

I'm working on a taskbot that fills out this web form, and then clicks the "Create Pay Stub" button. I'm using object cloning. Pretty straightforward, right? But it's not working. The site works as expected in IE 11, if I open a new browser, navigate to the site, and click the button manually. Stops working as soon as I try to do this in AA.

Here are the important points:

  • The button changes color, so it's definitely being clicked on. But there's no effect.
  • The fields have been filled correctly, so that's not the issue. But even if they weren't , pressing the button would still have an effect. In my case, nothing is happening at all.
  • Every other button on the site works as expected, when I instruct my taskbot to click on it instead. It's just the "create pay stub" button.

I've tried installing the Flex and Silverlight plugins, I've tried introducing delays, I've tried using the web recorder to make clicking the submit button a separate task, I've tried locating the button by DOM xpath, class name, type... I've tried all that, but I'm still where I was three hours ago. What am I doing wrong?

BTW this is what you're supposed to see after filling out the form and pressing the button: it's a sort of popup. Let me know if you need any more information


  • I do also face similar issue. Any help appreciated

  • Are you using 'click' or 'left click'? 'click' is usually more reliable. Also, try capturing the button text to make sure you definitely have the right object.

Sign In or Register to comment.